summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCarlos Corbacho <carlos@strangeworlds.co.uk>2007-12-16 22:59:30 -0500
committerDavid Zeuthen <davidz@redhat.com>2007-12-16 22:59:30 -0500
commitba2003a9492a7ef1fabcb6ae7997cfc8e5f15adf (patch)
tree21036886ac9cd100a97bc09adc858393b4ce99d8 /configure.in
parent59081d0a25f6f3227ccba960fa486fd7111baeef (diff)
downloadpolkit-ba2003a9492a7ef1fabcb6ae7997cfc8e5f15adf.tar.gz
add Shadow authentication framework
Add Piter PUNK's polkit-grant-helper-shadow, and link against the appropriate libraries. For now, the Shadow framework must be explictily called - in future, this could also be added as a fallback if PAM is not available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a33767a..2fdb935 100644
--- a/configure.in
+++ b/configure.in
@@ -290,7 +290,7 @@ dnl ---------------------------------------------------------------------------
AC_ARG_WITH([authfw],
AS_HELP_STRING([--with-authfw=<name>],
- [Authentication framework (none/pam)]))
+ [Authentication framework (none/pam/shadow)]))
if ! test -z "$with_authfw" ; then
if test x$with_authdb = xdummy ; then
if ! test x$with_authfw = xnone ; then
@@ -324,6 +324,12 @@ case $POLKIT_AUTHFW in
AC_DEFINE(POLKIT_AUTHFW_PAM, 1, [If using the PAM authentication framework])
;;
+ shadow)
+ need_pam=no
+ AUTH_LIBS="${AUTH_LIBS} -lcrypt"
+ AC_DEFINE(POLKIT_AUTHFW_SHADOW, 1, [If using the Shadow authentication framework])
+ ;;
+
*)
AC_MSG_ERROR([Unknown Authentication Framework: $POLKIT_AUTHFW])
;;
@@ -331,6 +337,7 @@ esac
AM_CONDITIONAL(POLKIT_AUTHFW_NONE, [test x$POLKIT_AUTHFW = xnone], [Using no authfw])
AM_CONDITIONAL(POLKIT_AUTHFW_PAM, [test x$POLKIT_AUTHFW = xpam], [Using PAM authfw])
+AM_CONDITIONAL(POLKIT_AUTHFW_SHADOW, [test x$POLKIT_AUTHFW = xshadow], [Using Shadow authfw])
dnl ---------------------------------------------------------------------------