summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2012-02-24 13:13:17 +0100
committerColin Walters <walters@verbum.org>2013-04-11 13:20:47 -0400
commite267e965ac30e29cb2de1e2ba668e7d00ab5b700 (patch)
treeb1365c8266524b9f1c99329494b6d9feb4545374 /configure.ac
parent80a10b589fa606930b0dab2e2613e77b734d9a6b (diff)
downloadpolkit-e267e965ac30e29cb2de1e2ba668e7d00ab5b700.tar.gz
polkitagent, pkexec: Respect SUID_CFLAGS and SUID_LDFLAGS
This is a good way for distributors to use -fPIE/-pie. https://bugs.freedesktop.org/attachment.cgi?id=57584
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b1e478b..a9c24c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -479,6 +479,11 @@ AC_SUBST([GETTEXT_PACKAGE])
AM_GLIB_GNU_GETTEXT
AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[gettext domain])
+AC_ARG_VAR([SUID_CFLAGS],
+ [CFLAGS used for binaries which are usually with the suid bit])
+AC_ARG_VAR([SUID_LDFLAGS],
+ [LDFLAGS used for binaries which are usually with the suid bit])
+
AC_OUTPUT([
Makefile
actions/Makefile