summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2020-10-28 12:02:04 +0100
committerJan Rybar <jrybar@redhat.com>2021-07-29 17:16:35 +0200
commit96c6fc83538fc28d1b3923b8be1eba2648f30e28 (patch)
tree319bfbd0c8fe86c3d16e97cb09267507abff2563 /configure.ac
parente336bf86d8b8489a4643500925e4da4eeb9000ba (diff)
downloadpolkit-96c6fc83538fc28d1b3923b8be1eba2648f30e28.tar.gz
build: Migrate from Intltool to Gettext
Recent versions of Gettext are able to translate several formats that are used in GNOME applications. This migrates from Intltool to Gettext both autotools and meson build systems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9b03959..ecfee05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,11 +519,13 @@ AM_CONDITIONAL(BUILD_EXAMPLES, test "x$enable_examples" = "xyes")
# Internationalization
# ********************
-IT_PROG_INTLTOOL([0.40.0])
+AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION([0.19.8])
+AM_GNU_GETTEXT_REQUIRE_VERSION([0.19.8])
+
GETTEXT_PACKAGE=polkit-1
-AC_SUBST([GETTEXT_PACKAGE])
-AM_GLIB_GNU_GETTEXT
-AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[gettext domain])
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[gettext domain])
AC_ARG_VAR([SUID_CFLAGS],
[CFLAGS used for binaries which are usually with the suid bit])
@@ -537,6 +539,8 @@ data/Makefile
data/polkit-1
data/polkit-gobject-1.pc
data/polkit-agent-1.pc
+gettext/Makefile
+gettext/its/Makefile
src/Makefile
src/polkit/Makefile
src/polkitbackend/Makefile