summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Linton <jeremy.linton@arm.com>2016-08-26 14:01:47 -0500
committerColin Walters <walters@verbum.org>2016-12-12 12:10:29 -0500
commit03dafd1fac8154c0a581395f1b7bf29e56a83491 (patch)
treedf526a532f41721146b5d88fe619d4ae83f9a9a6 /configure.ac
parent0676f33aa741a87634ffc3b9ef82c7d092c997ec (diff)
downloadpolkit-03dafd1fac8154c0a581395f1b7bf29e56a83491.tar.gz
Switch to hard requiring mozjs24
Remove mozjs185 and mozjs17 from autoconf and replace them with mozjs24. Now that polkitbackendjsauthority is compiling in C++ mode and the autoconf supports mozjs24, update the module so that it builds with mozjs24. Signed-off-by: Jeremy Linton <jeremy.linton@arm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 2 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 18c1f4e..f457a84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,18 +131,8 @@ AC_DEFINE([GLIB_VERSION_MIN_REQUIRED], [GLIB_VERSION_2_30],
AC_DEFINE([GLIB_VERSION_MAX_ALLOWED], [G_ENCODE_VERSION(2,34)],
[Notify us when we'll need to transition away from g_type_init()])
-AC_ARG_WITH(mozjs, AS_HELP_STRING([--with-mozjs=@<:@mozjs185/mozjs-17.0|auto@:>@],
- [Specify version of Spidermonkey to use]),,
- with_mozjs=auto)
-AS_IF([test x${with_mozjs} != xauto], [
- PKG_CHECK_MODULES(LIBJS, ${with_mozjs})
-], [
- PKG_CHECK_MODULES(LIBJS, [mozjs185], have_mozjs185=yes, have_mozjs185=no)
- AS_IF([test x${have_mozjs185} = xno], [
- PKG_CHECK_MODULES(LIBJS, [mozjs-17.0], have_mozjs17=yes,
- [AC_MSG_ERROR([Could not find mozjs185 or mozjs-17.0; see http://ftp.mozilla.org/pub/mozilla.org/js/])])
- ])
-])
+PKG_CHECK_MODULES(LIBJS, [mozjs-24])
+
AC_SUBST(LIBJS_CFLAGS)
AC_SUBST(LIBJS_CXXFLAGS)
AC_SUBST(LIBJS_LIBS)