summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Rybar <jrybar@redhat.com>2022-05-09 15:45:33 +0200
committerJan Rybar <jrybar@redhat.com>2022-05-09 15:45:33 +0200
commitc5c6b784221b9dc054548c15e94719c4e961a7f2 (patch)
tree4716bf018665205d5d3add11e3c9e69d67e8f165 /Makefile.am
parent7d4b52c4d71c46049d87a0775de695ea914f3f1b (diff)
downloadpolkit-c5c6b784221b9dc054548c15e94719c4e961a7f2.tar.gz
Remove autotools build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am44
1 files changed, 0 insertions, 44 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index 1ac687a..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-## Process this file with automake to produce Makefile.in
-
-SUBDIRS = actions data gettext src docs po
-
-if BUILD_TEST
-SUBDIRS += test
-endif
-
-NULL =
-
-EXTRA_DIST = \
- HACKING.md \
- meson.build \
- meson_options.txt \
- meson_post_install.py \
- po/meson.build \
- $(NULL)
-
-# xsltproc barfs on 'make distcheck'; disable for now
-DISTCHECK_CONFIGURE_FLAGS= \
- --disable-man-pages \
- --disable-introspection \
- --enable-gtk-doc \
- --with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir) \
- --enable-libsystemd-login=yes \
- --enable-libelogind=no \
- $(NULL)
-
-sign : dist
- gpg --armor --detach-sign --output polkit-$(VERSION).tar.gz.sign polkit-$(VERSION).tar.gz
-
-publish : sign
- scp polkit-$(VERSION).tar.gz polkit-$(VERSION).tar.gz.sign "jrybar@people.freedesktop.org:/srv/www.freedesktop.org/www/software/polkit/releases/"
-
-publish-docs :
- gtkdoc-rebase --html-dir docs/polkit/html --online
- ssh "jrybar@people.freedesktop.org" "mkdir -p /srv/www.freedesktop.org/www/software/polkit/docs/$(VERSION)"
- scp docs/polkit/html/* "jrybar@people.freedesktop.org:/srv/www.freedesktop.org/www/software/polkit/docs/$(VERSION)"
- ssh "jrybar@people.freedesktop.org" "rm -f /srv/www.freedesktop.org/www/software/polkit/docs/latest; ln -s $(VERSION) /srv/www.freedesktop.org/www/software/polkit/docs/latest"
-
-clean-local :
- rm -f *~
-
--include $(top_srcdir)/git.mk