summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2012-04-24 12:39:27 -0400
committerDavid Zeuthen <davidz@redhat.com>2012-04-24 12:39:27 -0400
commita7e4674b9a30e28d1fe238db735c37b52e3af72d (patch)
treed617deca3c7e05ae23c484f8e63d00d47dd81c10 /Makefile.am
parentc0307cdf6912a5fbe45fea8883c93a42133e3e00 (diff)
downloadpolkit-a7e4674b9a30e28d1fe238db735c37b52e3af72d.tar.gz
Add Makefile rules for signing and publishing releases and docs
Also mention in README how the authenticity of releases can be verified. Signed-off-by: David Zeuthen <davidz@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 70d072c..01f0a4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,5 +11,17 @@ EXTRA_DIST = \
# xsltproc barfs on 'make distcheck'; disable for now
DISTCHECK_CONFIGURE_FLAGS=--disable-man-pages --disable-gtk-doc --disable-introspection
+sign : dist
+ gpg --armor --detach-sign --output polkit-$(VERSION).tar.gz.sign polkit-$(VERSION).tar.gz
+
+publish : sign
+ scp polkit-$(VERSION).tar.gz polkit-$(VERSION).tar.gz.sign "david@people.freedesktop.org:/srv/www.freedesktop.org/www/software/polkit/releases/"
+
+publish-docs :
+ gtkdoc-rebase --html-dir docs/polkit/html --online
+ ssh "david@people.freedesktop.org" "mkdir -p /srv/www.freedesktop.org/www/software/polkit/docs/$(VERSION)"
+ scp docs/polkit/html/* "david@people.freedesktop.org:/srv/www.freedesktop.org/www/software/polkit/docs/$(VERSION)"
+ ssh "david@people.freedesktop.org" "rm -f /srv/www.freedesktop.org/www/software/polkit/docs/latest; ln -s $(VERSION) /srv/www.freedesktop.org/www/software/polkit/docs/latest"
+
clean-local :
rm -f *~