summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 33 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3010b8f..d0baabd 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
AC_INIT(pkg-config.1)
-AM_INIT_AUTOMAKE(pkgconfig, 0.16.0)
+AM_INIT_AUTOMAKE(pkgconfig, 0.16.1)
AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
@@ -24,6 +24,38 @@ dnl AC_DEFINE_UNQUOTED(PKG_CONFIG_PC_PATH,["$pc_path"],[Default search path for
PKG_CONFIG_FIND_PC_PATH
+#
+# Code taken from gtk+-2.0's configure.in.
+#
+# This causes pkg-config to only list direct dependencies on platforms
+# which support inter-library dependencies.
+#
+
+AC_ARG_ENABLE(indirect-deps,
+ [AC_HELP_STRING([--enable-indirect-deps=@<:@yes/no/auto@:>@],
+ [list both direct and indirect dependencies. [default=auto]])],,
+ [enable_indirect_deps=auto])
+
+AC_MSG_CHECKING([Whether to list both direct and indirect dependencies])
+case $enable_indirect_deps in
+ auto)
+ deplib_check_method=`(./libtool --config; echo eval echo \\$deplib_check_method) | sh`
+ if test "X$deplib_check_method" = Xnone || test "x$enable_static" = xyes ; then
+ enable_indirect_deps=yes
+ else
+ enable_indirect_deps=no
+ fi
+ ;;
+ yes|no)
+ ;;
+ *) AC_MSG_ERROR([Value given to --enable-indirect-deps must be one of yes, no
+or auto])
+ ;;
+esac
+AC_MSG_RESULT($enable_explicit_deps)
+
+AC_DEFINE_UNQUOTED(ENABLE_INDIRECT_DEPS, `test $enable_indirect_deps = yes; echo $?`, [Indirect shared library dependencies enabled])
+
AC_MSG_CHECKING([for Win32])
case "$host" in
*-*-mingw*)