summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index b9edccc..7681d2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,9 @@ GLIB_SUBDIR = glib-1.2.10
included_glib_includes = -I./glib-1.2.10
pkg_config_LDADD=glib-1.2.10/libglib.la
endif
-SUBDIRS = $(GLIB_SUBDIR) check
+pkg_config_LDADD += popt/libpopt.la
+popt_includes = -I./popt
+SUBDIRS = $(GLIB_SUBDIR) popt check
m4dir = $(datadir)/aclocal
m4_DATA = pkg.m4
@@ -19,7 +21,8 @@ EXTRA_DIST = $(m4_DATA) $(man_MANS) README.win32
bin_PROGRAMS = pkg-config
AM_CFLAGS=@WARN_CFLAGS@
-INCLUDES=-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" $(included_glib_includes)
+INCLUDES=-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" $(included_glib_includes) \
+ $(popt_includes)
pkg_config_SOURCES= \
pkg.h \
@@ -28,11 +31,4 @@ pkg_config_SOURCES= \
parse.c \
main.c \
findme.c \
- findme.h \
- popt.c \
- popt.h \
- poptconfig.c \
- popthelp.c \
- poptint.h \
- poptparse.c
-
+ findme.h