summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2010-06-17 08:56:50 -0700
committerDan Nicholson <dbn.lists@gmail.com>2012-05-14 14:19:10 -0700
commitfd4d40b94e8333435933b01b9c62054bdb6cb6ee (patch)
treef1f407474dfee90f228440f1ed393d8d415f7073 /configure.ac
parente91ab1009aace6386584766df553ef7105222c44 (diff)
downloadpkg-config-fd4d40b94e8333435933b01b9c62054bdb6cb6ee.tar.gz
Drop popt usage and remove unused popt sources
With the conversion to GOption and g_shell_parse_argv, pkg-config has no remaining usage of popt. Stop linking to libpopt and removed the bundled sources. Fixes Freedesktop #5326, #31700, #44843
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index b730834..4290e60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,28 +144,11 @@ fi
AC_SUBST(GLIB_LIBS)
AC_SUBST(GLIB_CFLAGS)
-AC_ARG_WITH([installed-popt],
- [AS_HELP_STRING([--with-installed-popt], [use installed popt library])],
- [with_installed_popt="$withval"],
- [with_installed_popt=no])
-if test "x$with_installed_popt" = xyes; then
- _save_libs="$LIBS"
- AC_CHECK_LIB([popt], [poptGetContext], [:],
- [AC_MSG_ERROR([could not link to installed popt library])])
- LIBS="$_save_libs"
- POPT_LIBS=-lpopt
-else
- POPT_LIBS=""
-fi
-AC_SUBST([POPT_LIBS])
-AM_CONDITIONAL([USE_INSTALLED_POPT], [test "x$with_installed_popt" = xyes])
-
AC_FUNC_ALLOCA
AC_CHECK_FUNCS(setresuid setreuid,break)
AC_CHECK_HEADERS([dirent.h unistd.h sys/wait.h malloc.h])
AC_OUTPUT([Makefile
- popt/Makefile
check/Makefile
check/config.sh])