summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2013-03-21 02:14:08 +0100
committerDan Nicholson <dbn.lists@gmail.com>2013-04-09 05:41:38 -0700
commitdf1ac943d468b48782f4ac81a880627dc0aebb2d (patch)
tree772186fe2e9a9bf5a5b1e7d2f80348f19f58ccd5 /configure.ac
parent4ccdb947dd2696afee23adfa36b7e4d3be8dedfa (diff)
downloadpkg-config-df1ac943d468b48782f4ac81a880627dc0aebb2d.tar.gz
Check $host rather than $build when deciding native Win32
The host triplet describes the machine the program will run on while the build triplet describes the machine the program is being built on. The determination of native Win32 should be based on where pkg-config is going to be running. This makes pkg-config cross-compiled for windows work as if it was built on windows.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2b33371..4ed7e4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,7 +138,7 @@ fi
AC_SUBST(WARN_CFLAGS)
AC_MSG_CHECKING([for Win32])
-case "$build" in
+case "$host" in
*-*-mingw*)
native_win32=yes
;;