summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2015-09-26 12:28:02 -0700
committerDan Nicholson <dbn.lists@gmail.com>2015-09-26 15:01:37 -0700
commit7e8b0bf6d9e003fe9877fac55ce31205d2433e18 (patch)
tree6880162e4281ad106ebfb83f04b614818f581b4e /configure.ac
parentd377ee6b740373895cb67cdc14a98c0d71650e05 (diff)
downloadpkg-config-7e8b0bf6d9e003fe9877fac55ce31205d2433e18.tar.gz
m4: Process pkg.m4 through AC_CONFIG_FILES
Currently there are no substitutions needed in pkg.m4, but this will allow autoconf values such as the package version to be included.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 388c013..6cc3bb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,7 +195,7 @@ dnl g_win32_get_package_installation_directory_of_module().
dnl
dnl Pull in pkg-config macros to find external glib.
dnl
-m4_include([pkg.m4])
+m4_include([pkg.m4.in])
m4_define([glib_module], [glib-2.0 >= 2.16])
AC_ARG_WITH([internal-glib],
[AS_HELP_STRING([--with-internal-glib], [use internal glib])],
@@ -255,6 +255,7 @@ AM_CONDITIONAL([HOST_TOOL], [test "x$enable_host_tool" = xyes])
AC_CONFIG_FILES([
Makefile
+pkg.m4
check/Makefile
check/config.sh
])