summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2011-04-14 07:25:43 +0400
committerTollef Fog Heen <tfheen@err.no>2011-04-14 08:19:50 +0200
commit7850aeb03a54a15d07b6c243b61033cd379c39d7 (patch)
tree13d9062d06807e049feb13ae43f7c07a3e6e36f0 /configure.ac
parent01005bbbd0155b606c1f3df845ccfaff81e0c6ff (diff)
downloadpkg-config-7850aeb03a54a15d07b6c243b61033cd379c39d7.tar.gz
Escape slashes in paths passed to mingw-gcc
Avoids Msys path mangling that turns *nix paths (such as /usr/include) into DOS-style absolute paths (such as c:/mingw/msys/1.0/include). Allows mingw-built pkg-config to pass check-cflags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ace5682..da875f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,7 @@ AC_DEFINE_UNQUOTED(ENABLE_INDIRECT_DEPS, `test $use_indirect_deps = no; echo $?`
AC_SUBST(use_indirect_deps)
AC_MSG_CHECKING([for Win32])
-case "$host" in
+case "$build" in
*-*-mingw*)
native_win32=yes
;;
@@ -116,6 +116,7 @@ case "$host" in
;;
esac
AC_MSG_RESULT([$native_win32])
+AM_CONDITIONAL(NATIVE_WIN32, [test "x$native_win32" = xyes])
if test "x$GLIB_CFLAGS" = "x" && test "x$GLIB_LIBS" = "x"; then
AC_CHECK_PROGS([PKG_CONFIG], [pkg-config], [])