summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-12-16 09:18:48 -0800
committerDan Nicholson <dbn.lists@gmail.com>2012-12-19 07:20:05 -0800
commit72e1346d044ccf72735b2c4a2e72f79fa20b236b (patch)
tree22f650c854b48800ac9a099e4bdb8acbffccf06c /configure.ac
parent5b463c927b6caeb332bb147572ea82b1650ceb7d (diff)
downloadpkg-config-72e1346d044ccf72735b2c4a2e72f79fa20b236b.tar.gz
Add root /lib* directories to the default -L paths
Avoids outputting -L/lib, which the linker will search in implicitly like -L/usr/lib. Freedesktop #58363 (https://bugs.freedesktop.org/show_bug.cgi?id=58363)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7e887d4..2b79704 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,10 +75,10 @@ AC_ARG_WITH([system_library_path],
[
case "$libdir" in
*lib64)
- system_library_path="/usr/lib64:/usr/lib"
+ system_library_path="/usr/lib64:/lib64:/usr/lib:/lib"
;;
*)
- system_library_path="/usr/lib"
+ system_library_path="/usr/lib:/lib"
;;
esac
])