summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-12-11 07:10:48 -0800
committerDan Nicholson <dbn.lists@gmail.com>2012-12-11 11:59:40 -0800
commit1b47b03c2a159aa1a70a3ea3949a9acb13ab4256 (patch)
treee5b7b1e0dc3512c3826b38639b97a56f61aba174 /configure.ac
parent30e7f3131875b71dcd056d82bbade2e8f00d1e70 (diff)
downloadpkg-config-1b47b03c2a159aa1a70a3ea3949a9acb13ab4256.tar.gz
Convert ints used as bools to gbooleans
This matches the GOption documentation that G_OPTION_ARG_NONE should use a gboolean.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bfb802c..7e887d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,7 +123,7 @@ or auto])
esac
AC_MSG_RESULT($use_indirect_deps)
AC_DEFINE_UNQUOTED([ENABLE_INDIRECT_DEPS],
- [`test $use_indirect_deps = no; echo $?`],
+ [`test $use_indirect_deps = yes && echo TRUE || echo FALSE`],
[Link library to all dependent libraries, not only directly needed ones])
AC_SUBST([use_indirect_deps])