summaryrefslogtreecommitdiff
path: root/check/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2016-01-29 10:36:04 -0800
committerDan Nicholson <dbn.lists@gmail.com>2016-02-26 08:56:52 -0800
commita3e58e7d4d624eb5a7898fc550b30d4c9bdffe71 (patch)
tree31f32ec4ce003b78c14183276ea4a469e34948ea /check/Makefile.am
parent1c564a358303a8396dc71cc92d79bd0ac304b15c (diff)
downloadpkg-config-a3e58e7d4d624eb5a7898fc550b30d4c9bdffe71.tar.gz
check: More thoroughly test variable usage
Add some more tests for handling unusual variables such as those that are quoted or that contain shell characters. This should help make the --variable output more reliable in the future. https://bugs.freedesktop.org/show_bug.cgi?id=93284
Diffstat (limited to 'check/Makefile.am')
-rw-r--r--check/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/check/Makefile.am b/check/Makefile.am
index 4f92e0d..d4000d8 100644
--- a/check/Makefile.am
+++ b/check/Makefile.am
@@ -28,6 +28,7 @@ TESTS = \
check-tilde \
check-relocatable \
check-variable-override \
+ check-variables \
$(NULL)
EXTRA_DIST = \
@@ -99,4 +100,6 @@ EXTRA_DIST = \
tilde.pc \
pkgconfig/prefixdef.pc \
pkgconfig/prefixdef-expanded.pc \
- pcfiledir.pc
+ pcfiledir.pc \
+ variables.pc \
+ $(NULL)