summaryrefslogtreecommitdiff
path: root/check/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2017-03-20 10:23:55 -0500
committerDan Nicholson <dbn.lists@gmail.com>2017-03-20 11:06:00 -0500
commit1dfe95b8b85a0d515d8c53d711dd26627859ed3f (patch)
treee6f8eb0f32ba5534d72caa8c99519da6d09982d2 /check/Makefile.am
parent309c1787a1d4f7f7a4cfb444c1e34d339f819a49 (diff)
downloadpkg-config-1dfe95b8b85a0d515d8c53d711dd26627859ed3f.tar.gz
check: Add test for system flags pruning
Test that pkg-config respects the various environment variables that override the system flags handling. https://bugs.freedesktop.org/show_bug.cgi?id=94729
Diffstat (limited to 'check/Makefile.am')
-rw-r--r--check/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/check/Makefile.am b/check/Makefile.am
index cf26019..68c6d84 100644
--- a/check/Makefile.am
+++ b/check/Makefile.am
@@ -30,6 +30,7 @@ TESTS = \
check-variable-override \
check-variables \
check-dependencies \
+ check-system-flags \
$(NULL)
EXTRA_DIST = \
@@ -116,4 +117,5 @@ EXTRA_DIST = \
dependencies/i_dep_k_j.pc \
dependencies/j_dep_k.pc \
dependencies/k_dep.pc \
+ system.pc \
$(NULL)