summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2010-06-17 08:56:50 -0700
committerDan Nicholson <dbn.lists@gmail.com>2012-05-14 14:19:10 -0700
commitfd4d40b94e8333435933b01b9c62054bdb6cb6ee (patch)
treef1f407474dfee90f228440f1ed393d8d415f7073 /Makefile.am
parente91ab1009aace6386584766df553ef7105222c44 (diff)
downloadpkg-config-fd4d40b94e8333435933b01b9c62054bdb6cb6ee.tar.gz
Drop popt usage and remove unused popt sources
With the conversion to GOption and g_shell_parse_argv, pkg-config has no remaining usage of popt. Stop linking to libpopt and removed the bundled sources. Fixes Freedesktop #5326, #31700, #44843
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 5 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index bbc5075..3bbcd6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,19 +4,11 @@ if INTERNAL_GLIB
GLIB_SUBDIR = glib
endif
-if USE_INSTALLED_POPT
-pkg_config_LDADD += $(POPT_LIBS)
-else
-pkg_config_LDADD += popt/libpopt.la
-popt_includes = -I$(top_srcdir)/popt
-POPT_SUBDIR = popt
-endif
-
-SUBDIRS = $(GLIB_SUBDIR) $(POPT_SUBDIR) . check
+SUBDIRS = $(GLIB_SUBDIR) . check
# normally we'd want glib to be part of DIST_SUBDIRS unconditionally,
# but distclean gets broken unless we always run glib's configure
-DIST_SUBDIRS = $(GLIB_SUBDIR) popt . check
+DIST_SUBDIRS = $(GLIB_SUBDIR) . check
m4dir = $(datadir)/aclocal
m4_DATA = pkg.m4
@@ -34,15 +26,13 @@ INCLUDES= \
-DPKG_CONFIG_PC_PATH="\"$(subst /,\/,$(pc_path))\"" \
-DPKG_CONFIG_SYSTEM_INCLUDE_PATH="\"$(subst /,\/,$(system_include_path))\"" \
-DPKG_CONFIG_SYSTEM_LIBRARY_PATH="\"$(subst /,\/,$(system_library_path))\"" \
- @GLIB_CFLAGS@ \
- $(popt_includes)
+ @GLIB_CFLAGS@
else
INCLUDES= \
-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" \
-DPKG_CONFIG_SYSTEM_INCLUDE_PATH="\"$(system_include_path)\"" \
-DPKG_CONFIG_SYSTEM_LIBRARY_PATH="\"$(system_library_path)\"" \
- @GLIB_CFLAGS@ \
- $(popt_includes)
+ @GLIB_CFLAGS@
endif
pkg_config_SOURCES= \
@@ -55,7 +45,7 @@ pkg_config_SOURCES= \
# Since we can't always have glib in DIST_SUBDIRS, we need to make sure
# glib is configured when we want to run dist. Unfortunately, there's no
# DIST_CONFIGURE_FLAGS.
-DISTCHECK_CONFIGURE_FLAGS = --with-installed-popt --with-internal-glib
+DISTCHECK_CONFIGURE_FLAGS = --with-internal-glib
if !INTERNAL_GLIB
dist-hook:
@echo "error: --with-internal-glib is required to include glib in dist"