summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-05-10 08:16:14 -0700
committerDan Nicholson <dbn.lists@gmail.com>2012-05-10 08:16:14 -0700
commitfb458a87b9e9bcbd017de639b1c645fffb3d92bf (patch)
tree1da97db55b77f2ad3af5ca98284384cc961faae0 /Makefile.am
parentb32156ab2b365b4210257d10d2fb7570d968ce2a (diff)
downloadpkg-config-fb458a87b9e9bcbd017de639b1c645fffb3d92bf.tar.gz
Revert "Make sure glib subdir is configure before dist"
This reverts commit 1860fc8036800683c04958f81c88558d08b6847e. distclean breaks if glib is in DIST_SUBDIRS but we haven't actually generated the glib Makefiles by running glib's configure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 0 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 8eb1d52..082b03d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,13 +48,3 @@ pkg_config_SOURCES= \
parse.c \
main.c
DISTCHECK_CONFIGURE_FLAGS = --with-installed-popt --with-internal-glib
-
-# Override the normal dist so that we can make sure the glib subdir is
-# configured first. Otherwise it will just bomb entering the directory.
-dist dist-all: check-glib-Makefile
- @$(MAKE) $(AM_MAKEFLAGS) dist-gzip
-check-glib-Makefile:
- @if test ! -f glib/Makefile; then \
- echo $(SHELL) $(top_srcdir)/configure --with-internal-glib; \
- $(SHELL) $(top_srcdir)/configure --with-internal-glib; \
- fi