summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2005-07-14 13:06:23 +0000
committerArch Librarian <arch@canonical.com>2005-07-14 13:06:23 +0000
commitd2080ec6d8503f6a97f1db8d6dcfbf14cb98d736 (patch)
treeaa1aa2cb826ebb3127e1d93eb56c4aa8659c6a8b /Makefile.am
parent03723d4caa2d0b9294b248c3cf9c4b8d1c2a73b4 (diff)
downloadpkg-config-d2080ec6d8503f6a97f1db8d6dcfbf14cb98d736.tar.gz
2005-03-18 Tollef Fog Heen <tfheen@err.no>
Author: tfheen Date: 2005-03-26 14:59:26 GMT 2005-03-18 Tollef Fog Heen <tfheen@err.no> * main.c (main): Use add_search_dirs for both the compile-time defined pc_path and the run-time defined PKG_CONFIG_PATH. * pkg.h: Add prototype for add_search_dirs. * pkg.c (add_search_dirs): Add new function which takes a delimiter-separated list as input and add_search_dir's it. (package_init): Remove knowledge about which dirs should be initially added. Moved this to main.c(main) * ChangeLog: Add emacs variables to set the date to this ChangeLog's standard format * Makefile.am (INCLUDES): Pass PKG_CONFIG_PCPATH on to main.c * configure.in: Add --with-pc-path to define the default search path for .pc files. (Freedesktop #119, #648)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 18a597e..b0eda07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,7 +15,7 @@ EXTRA_DIST = $(m4_DATA) $(man_MANS) README.win32
bin_PROGRAMS = pkg-config
-INCLUDES=-DPKGLIBDIR="\"$(pkglibdir)\"" $(included_glib_includes)
+INCLUDES=-DPKG_CONFIG_PC_PATH="\"$(pc_path)\"" $(included_glib_includes)
pkg_config_SOURCES= \
pkg.h \