summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2020-05-30 11:42:22 +0100
committerMatt Turner <mattst88@gmail.com>2020-06-02 02:30:39 +0000
commit606f5c15b0e7959087e1a22c8d9f594afaf1ead0 (patch)
treedc939534c03799d0e64bfc3b32ccef32b603949e /meson.build
parent15e066861633f36ac00e5b381f9c808e024ad74d (diff)
downloadpixman-606f5c15b0e7959087e1a22c8d9f594afaf1ead0.tar.gz
meson: add option to skip building of tests and demos
Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 91d6578..72ad8b9 100644
--- a/meson.build
+++ b/meson.build
@@ -534,8 +534,11 @@ version_conf.set('PIXMAN_VERSION_MICRO', split[2])
add_project_arguments('-DHAVE_CONFIG_H', language : ['c'])
subdir('pixman')
-subdir('test')
-subdir('demos')
+
+if not get_option('tests').disabled()
+ subdir('test')
+ subdir('demos')
+endif
pkg = import('pkgconfig')
pkg.generate(