summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDonald Stufft <donald@stufft.io>2014-01-28 09:17:51 -0500
committerDonald Stufft <donald@stufft.io>2014-01-28 19:47:58 -0500
commit9f027337a8f54ab411848b90f98533a7855dac4d (patch)
tree76cae75c5f31d1722ad16589d81ca4d80838d8ea /setup.py
parent9efff5571592aecc9b1eb6d7b3dc51930763a68e (diff)
downloadpip-9f027337a8f54ab411848b90f98533a7855dac4d.tar.gz
Use Flake8 on the test of pip's Python files
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py82
1 files changed, 44 insertions, 38 deletions
diff --git a/setup.py b/setup.py
index 961da9684..e73a9d4c0 100644
--- a/setup.py
+++ b/setup.py
@@ -25,8 +25,8 @@ class PyTest(TestCommand):
def read(*parts):
- # intentionally *not* adding an encoding option to open
- # see here: https://github.com/pypa/virtualenv/issues/201#issuecomment-3145690
+ # intentionally *not* adding an encoding option to open, See:
+ # https://github.com/pypa/virtualenv/issues/201#issuecomment-3145690
return codecs.open(os.path.join(here, *parts), 'r').read()
@@ -43,40 +43,46 @@ long_description = "\n" + "\n".join([read('PROJECT.txt'),
tests_require = ['pytest', 'virtualenv>=1.10', 'scripttest>=1.3', 'mock']
-setup(name="pip",
- version=find_version('pip', '__init__.py'),
- description="A tool for installing and managing Python packages.",
- long_description=long_description,
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Topic :: Software Development :: Build Tools',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
- ],
- keywords='easy_install distutils setuptools egg virtualenv',
- author='The pip developers',
- author_email='python-virtualenv@groups.google.com',
- url='http://www.pip-installer.org',
- license='MIT',
- packages=find_packages(exclude=["contrib", "docs", "tests*"]),
- package_data={
- 'pip._vendor.requests': ['*.pem'],
- 'pip._vendor.distlib._backport': ['sysconfig.cfg'],
- 'pip._vendor.distlib': ['t32.exe', 't64.exe', 'w32.exe', 'w64.exe'],
- },
- entry_points=dict(console_scripts=['pip=pip:main', 'pip%s=pip:main' % sys.version[:1],
- 'pip%s=pip:main' % sys.version[:3]]),
- tests_require=tests_require,
- zip_safe=False,
- extras_require={
- 'testing': tests_require,
- },
- cmdclass = {'test': PyTest},
+setup(
+ name="pip",
+ version=find_version("pip", "__init__.py"),
+ description="A tool for installing and managing Python packages.",
+ long_description=long_description,
+ classifiers=[
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Topic :: Software Development :: Build Tools",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.1",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ ],
+ keywords='easy_install distutils setuptools egg virtualenv',
+ author='The pip developers',
+ author_email='python-virtualenv@groups.google.com',
+ url='http://www.pip-installer.org',
+ license='MIT',
+ packages=find_packages(exclude=["contrib", "docs", "tests*"]),
+ package_data={
+ 'pip._vendor.requests': ['*.pem'],
+ 'pip._vendor.distlib._backport': ['sysconfig.cfg'],
+ 'pip._vendor.distlib': ['t32.exe', 't64.exe', 'w32.exe', 'w64.exe'],
+ },
+ entry_points={
+ "console_scripts": [
+ "pip=pip:main",
+ "pip%s=pip:main" % sys.version[:1],
+ "pip%s=pip:main" % sys.version[:3],
+ ],
+ },
+ tests_require=tests_require,
+ zip_safe=False,
+ extras_require={
+ 'testing': tests_require,
+ },
+ cmdclass={'test': PyTest},
)