summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2020-12-27 15:48:06 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2021-02-19 04:13:33 -0800
commitd9b5525193c99fa222d6717f27ab72ca6fc0101b (patch)
treedb3d5e6736e569716ddc8ab18db16d09734c4c12 /pyproject.toml
parent8365bc3dcc21809f2fb86c4db5e40aaf2384c897 (diff)
downloadpip-d9b5525193c99fa222d6717f27ab72ca6fc0101b.tar.gz
Prefer stdlib contextlib over contextlib2 when available
Removes the vendored contextlib2. ExitStack and suppress are available from stdlib contextlib on all supported Python versions. The nullcontext context manager which isn't available in Python 3.6, but the function is simple to implement. Once Python 3.6 support is dropped, so too can the compat shim.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 04f725806..281594b21 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -49,7 +49,6 @@ drop = [
[tool.vendoring.typing-stubs]
six = ["six.__init__", "six.moves.__init__", "six.moves.configparser"]
appdirs = []
-contextlib2 = []
[tool.vendoring.license.directories]
setuptools = "pkg_resources"