summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@gmail.com>2019-12-15 04:00:07 +0530
committerPradyun Gedam <pradyunsg@gmail.com>2019-12-15 04:00:07 +0530
commitcdee9e2c331f8f16118e2e2d0ea403cdce8b8c27 (patch)
tree8e0359f9fe1a29551fdb8d0bee3732ab5d54ae79 /pyproject.toml
parent8e7a87bf4bdcb754f89bd47e2cc8300b79306f6a (diff)
downloadpip-cdee9e2c331f8f16118e2e2d0ea403cdce8b8c27.tar.gz
Add configuration for using vendoring
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index aa798360c..645d54a75 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -18,3 +18,42 @@ type = [
{ name = "Improved Documentation", directory = "doc", showcontent = true },
{ name = "Trivial Changes", directory = "trivial", showcontent = false },
]
+
+[tool.vendoring]
+destination = "src/pip/_vendor/"
+requirements = "src/pip/_vendor/vendor.txt"
+namespace = "pip._vendor"
+
+protected-files = ["__init__.py", "README.rst", "vendor.txt"]
+patches-dir = "tools/automation/vendoring/patches"
+
+[tool.vendoring.transformations]
+substitute = [
+ # pkg_resource's vendored packages are directly vendored in pip.
+ { match='pkg_resources\.extern', replace='pip._vendor' },
+ { match='from \.extern', replace='from pip._vendor' },
+]
+drop = [
+ # contains unnecessary scripts
+ "bin/",
+ # interpreter and OS specific msgpack libs
+ "msgpack/*.so",
+ # unneeded parts of setuptools
+ "easy_install.py",
+ "setuptools",
+ "pkg_resources/_vendor/",
+ "pkg_resources/extern/",
+]
+
+[tool.vendoring.typing-stubs]
+six = ["six.__init__", "six.moves.__init__", "six.moves.configparser"]
+appdirs = []
+contextlib2 = []
+
+[tool.vendoring.license.directories]
+setuptools = "pkg_resources"
+msgpack-python = "msgpack"
+
+[tool.vendoring.license.fallback-urls]
+pytoml = "https://github.com/avakar/pytoml/raw/master/LICENSE"
+webencodings = "https://github.com/SimonSapin/python-webencodings/raw/master/LICENSE"