summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@users.noreply.github.com>2021-10-14 08:00:40 +0100
committerPradyun Gedam <pradyunsg@users.noreply.github.com>2021-10-14 08:00:40 +0100
commit858dd34af6d792e122715ac10374d0d8380ac9d4 (patch)
treef5384f6f3f780920f84563b463d4b37738f0b040 /pyproject.toml
parent75c11c4d7b6bea977bc107ef672017926ef79114 (diff)
downloadpip-858dd34af6d792e122715ac10374d0d8380ac9d4.tar.gz
Upgrade to vendoring 1.2
This enables wheel usage in vendoring's license fetching, at the cost of requiring two more license-related fallbacks. The additional fallbacks are due to packages which include the license in their source distributions but not in their wheel distributions, and the change in vendoring that prefers using wheels when possible. This should fix the bootstrapping problem we're seeing with `flit` and `tomli`, by allowing us to use wheels to break the loop.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index fac279447..9bb5900d0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -54,4 +54,6 @@ distro = []
setuptools = "pkg_resources"
[tool.vendoring.license.fallback-urls]
+CacheControl = "https://raw.githubusercontent.com/ionrock/cachecontrol/v0.12.6/LICENSE.txt"
+distlib = "https://bitbucket.org/pypa/distlib/raw/master/LICENSE.txt"
webencodings = "https://github.com/SimonSapin/python-webencodings/raw/master/LICENSE"