summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@users.noreply.github.com>2021-11-05 12:44:54 +0000
committerPradyun Gedam <pradyunsg@users.noreply.github.com>2021-11-26 11:50:21 +0000
commit7510fb04b6d12487a7de2d49cad8cb29366a6ae2 (patch)
treeba62f995a40f45a06c0b288715ad29d678a436be /pyproject.toml
parentc6037c7bbda548caae24b3df698ee6cbc5b0d67a (diff)
downloadpip-7510fb04b6d12487a7de2d49cad8cb29366a6ae2.tar.gz
Vendor rich and required dependencies (pygments, typing_extensions)
This will enable building upon these libraries, to improve the presentation style and output.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 53343bfce..f14f34250 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -39,6 +39,7 @@ substitute = [
# pkg_resource's vendored packages are directly vendored in pip.
{ match='pkg_resources\.extern', replace="pip._vendor" },
{ match='from \.extern', replace="from pip._vendor" },
+ { match='''\('pygments\.lexers\.''', replace="('pip._vendor.pygments.lexer." },
]
drop = [
# contains unnecessary scripts
@@ -50,6 +51,11 @@ drop = [
"setuptools",
"pkg_resources/_vendor/",
"pkg_resources/extern/",
+ # trim vendored pygments styles and lexers
+ "pygments/styles/[!_]*.py",
+ '^pygments/lexers/(?!python|__init__|_mapping).*\.py$',
+ # trim rich's markdown support
+ "rich/markdown.py",
]
[tool.vendoring.typing-stubs]