summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2021-08-02 07:42:41 -0700
committerXavier Fernandez <xav.fernandez@gmail.com>2021-08-15 21:54:40 +0200
commit3064f71161047cf57f55950a86b48d44cae83ced (patch)
tree7af67754d7c8aef2793d1335df41207f034ed9b8 /pyproject.toml
parent402bbcbd12ca68b5eac176fd7d651f0f0fa31057 (diff)
downloadpip-3064f71161047cf57f55950a86b48d44cae83ced.tar.gz
Upgrade vendored distro to use new typing and API
The most recent version of distro, 1.6.0, include type information. This allows pip to remove some workarounds. See upstream commit: https://github.com/python-distro/distro/commit/20cb68d6b00179135f1461d51972fb3395e75363 The new version also deprecated the top level function distro.linux_distribution(). Switch to the new preferred API. See upstream commit: https://github.com/python-distro/distro/commit/f947776f5a9f018325f0daa446b92d62f1811a91
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9f6dbe12a..f54c016ac 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -51,6 +51,7 @@ drop = [
[tool.vendoring.typing-stubs]
six = ["six.__init__", "six.moves.__init__", "six.moves.configparser"]
appdirs = []
+distro = []
[tool.vendoring.license.directories]
setuptools = "pkg_resources"