summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@gmail.com>2019-08-27 14:54:08 +0530
committerPradyun Gedam <pradyunsg@gmail.com>2019-08-27 14:54:08 +0530
commit026fd7bbe83100a4df50f5a77be099ddc609ad14 (patch)
treedecb9cfe13461eec6a50370c73c5d11135339f0d /pyproject.toml
parent3c9770d9b22b6e3e4de927ef8e1aa9c5155b74d6 (diff)
downloadpip-026fd7bbe83100a4df50f5a77be099ddc609ad14.tar.gz
Switch to inline tables in pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml44
1 files changed, 9 insertions, 35 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e3be2b3dc..919965c27 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -9,38 +9,12 @@ directory = "news/"
title_format = "{version} ({project_date})"
issue_format = "`#{issue} <https://github.com/pypa/pip/issues/{issue}>`_"
template = "news/_template.rst"
-
- [[tool.towncrier.type]]
- directory = "process"
- name = "Process"
- showcontent = true
-
- [[tool.towncrier.type]]
- directory = "removal"
- name = "Deprecations and Removals"
- showcontent = true
-
- [[tool.towncrier.type]]
- directory = "feature"
- name = "Features"
- showcontent = true
-
- [[tool.towncrier.type]]
- directory = "bugfix"
- name = "Bug Fixes"
- showcontent = true
-
- [[tool.towncrier.type]]
- directory = "vendor"
- name = "Vendored Libraries"
- showcontent = true
-
- [[tool.towncrier.type]]
- directory = "doc"
- name = "Improved Documentation"
- showcontent = true
-
- [[tool.towncrier.type]]
- directory = "trivial"
- name = "Trivial Changes"
- showcontent = false
+type = [
+ { name = "Process", directory = "process", showcontent = true },
+ { name = "Deprecations and Removals", directory = "removal", showcontent = true },
+ { name = "Features", directory = "feature", showcontent = true },
+ { name = "Bug Fixes", directory = "bugfix", showcontent = true },
+ { name = "Vendored Libraries", directory = "vendor", showcontent = true },
+ { name = "Improved Documentation", directory = "doc", showcontent = true },
+ { name = "Trivial Changes", directory = "trivial", showcontent = false },
+]