summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGary Kramlich <grim@reaperworld.com>2022-11-16 23:44:59 -0600
committerGary Kramlich <grim@reaperworld.com>2022-11-16 23:44:59 -0600
commit2b143dd78382a35175adaf3e659c1807f9133c3a (patch)
treeb5e31feaa7df191813535f0d3690aa5d36cf7ca7 /meson.build
parent21d0da8361143a970f1320c36d99e328015c6f06 (diff)
downloadpidgin-2b143dd78382a35175adaf3e659c1807f9133c3a.tar.gz
Remove soupcompat.h since we require libsoup3 now
Testing Done: Compiled Reviewed at https://reviews.imfreedom.org/r/2068/
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 5 insertions, 16 deletions
diff --git a/meson.build b/meson.build
index e1d0a487b7..178c616248 100644
--- a/meson.build
+++ b/meson.build
@@ -274,22 +274,11 @@ json = dependency('json-glib-1.0', version : '>= 0.14.0')
# Check for libsoup (required)
#######################################################################
-libsoup = disabler()
-if not get_option('soup2')
- libsoup = dependency('libsoup-3.0', version : '>= 3')
- add_project_arguments(
- '-DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_3_0',
- '-DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_3_0',
- language : 'c')
- soup_api_version = '3.0'
-else
- libsoup = dependency('libsoup-2.4', version : '>= 2.42')
- add_project_arguments(
- '-DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_42',
- '-DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_2_42',
- language : 'c')
- soup_api_version = '2.4'
-endif
+libsoup = dependency('libsoup-3.0', version : '>= 3')
+add_project_arguments(
+ '-DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_3_0',
+ '-DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_3_0',
+ language : 'c')
#######################################################################
# Check for sqlite3 (required)