summaryrefslogtreecommitdiff
path: root/ext/gd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gd/Makefile.am')
-rw-r--r--ext/gd/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/ext/gd/Makefile.am b/ext/gd/Makefile.am
index 6483056bfa..d767120564 100644
--- a/ext/gd/Makefile.am
+++ b/ext/gd/Makefile.am
@@ -1,15 +1,12 @@
## Process this file with automake to produce Makefile.in
-phplibdir=$(libdir)/php
-
SRC=gd.c gdcache.c gdttf.c
INCLUDES=@INCLUDES@ @GD_INCLUDES@ -I@top_srcdir@ -I@top_srcdir@/libzend
-noinst_LIBRARIES=@GD_STATIC@
-EXTRA_LIBRARIES=libphpext_gd.a
-libphpext_gd_a_SOURCES=$(SRC)
+noinst_LTLIBRARIES=@GD_STATIC@
+EXTRA_LTLIBRARIES=libphpext_gd.la gd.la
+libphpext_gd_la_SOURCES=$(SRC)
phplib_LTLIBRARIES=@GD_SHARED@
-EXTRA_LTLIBRARIES=gd.la
gd_la_SOURCES=$(SRC)
gd_la_LIBADD=@GD_LFLAGS@ @GD_LIBS@
gd_la_LDFLAGS=-avoid-version -module -rpath $(phplibdir)