summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoe Watkins <krakjoe@php.net>2017-01-03 06:48:40 +0000
committerJoe Watkins <krakjoe@php.net>2017-01-03 06:48:40 +0000
commit0788f3ed3c66db12187500fe089fb9cb5528783b (patch)
treea0a51f6360cd3e855ab499816538c0531a0721c0 /configure.in
parent6b985c71d4c748868f4959124639747fc748cf5a (diff)
parent81ce32a48fcb245f7a473bbd177686f52c09b854 (diff)
downloadphp-git-0788f3ed3c66db12187500fe089fb9cb5528783b.tar.gz
Merge branch 'pull-request/2163'
* pull-request/2163: import explicit_bzero + strlc* functions update since 1999 algorithms have changed and register k/w not necessary anymore.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index be73e1ebb7..ea52783903 100644
--- a/configure.in
+++ b/configure.in
@@ -745,7 +745,7 @@ if test "$ac_cv_func_sync_fetch_and_add" = yes; then
AC_DEFINE(HAVE_SYNC_FETCH_AND_ADD,1,[Define if you have the __sync_fetch_and_add function])
fi
-AC_REPLACE_FUNCS(strlcat strlcpy getopt)
+AC_REPLACE_FUNCS(strlcat strlcpy explicit_bzero getopt)
AC_FUNC_UTIME_NULL
AC_FUNC_ALLOCA
dnl PHP_AC_BROKEN_SPRINTF
@@ -1446,7 +1446,7 @@ PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=
PHP_ADD_SOURCES(main, main.c snprintf.c spprintf.c php_sprintf.c \
fopen_wrappers.c alloca.c php_scandir.c \
php_ini.c SAPI.c rfc1867.c php_content_types.c strlcpy.c \
- strlcat.c mergesort.c reentrancy.c php_variables.c php_ticks.c \
+ strlcat.c explicit_bzero.c mergesort.c reentrancy.c php_variables.c php_ticks.c \
network.c php_open_temporary_file.c \
output.c getopt.c, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)