summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <peterkokot@gmail.com>2019-03-19 23:49:26 +0100
committerPeter Kokot <peterkokot@gmail.com>2019-04-07 05:52:14 +0200
commitafd52f9d9986d92dd0c63832a07ab1a16bf11d53 (patch)
tree1bc5cd2b4ab427dcd104500affba7bf7ba6973f8 /configure.ac
parent3eae4f677a604a547a1847a4fb0ba54e813c90c9 (diff)
downloadphp-git-afd52f9d9986d92dd0c63832a07ab1a16bf11d53.tar.gz
Refactor AC_INIT in configure.ac and PHP versions
Since Autoconf 2.53 the AC_INIT call with only a single argument has been made obsolete and now includes several other optional arguments to make installation experience a bit better by providing program version and links to the project in the `./configure -h` output. This patch also updates win build version. The phpize.m4 AC_INIT has been updated with the call without arguments.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 3e51518195..6cce236364 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +8,8 @@ dnl Basic autoconf initialization, generation of config.nice.
dnl -------------------------------------------------------------------------
AC_PREREQ([2.68])
-AC_INIT([main/php_version.h])
+AC_INIT([PHP],[7.4.0-dev],[https://bugs.php.net],[php],[https://www.php.net])
+AC_CONFIG_SRCDIR([main/php_version.h])
AC_CONFIG_AUX_DIR([build])
AC_PRESERVE_HELP_ORDER
@@ -99,10 +100,13 @@ extern "C++" {
#endif /* PHP_CONFIG_H */
])
-PHP_MAJOR_VERSION=7
-PHP_MINOR_VERSION=4
-PHP_RELEASE_VERSION=0
-PHP_EXTRA_VERSION="-dev"
+ac_IFS=$IFS; IFS="."
+set $(echo AC_PACKAGE_VERSION | $SED 's/\([[0-9\.]]*\)\(.*\)/\1\.\2/')
+IFS=$ac_IFS
+PHP_MAJOR_VERSION=[$]1
+PHP_MINOR_VERSION=[$]2
+PHP_RELEASE_VERSION=[$]3
+PHP_EXTRA_VERSION=[$]4
PHP_VERSION="$PHP_MAJOR_VERSION.$PHP_MINOR_VERSION.$PHP_RELEASE_VERSION$PHP_EXTRA_VERSION"
PHP_VERSION_ID=`expr [$]PHP_MAJOR_VERSION \* 10000 + [$]PHP_MINOR_VERSION \* 100 + [$]PHP_RELEASE_VERSION`