summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Peter Banyard <girgias@php.net>2019-12-04 15:17:57 +0100
committerGeorge Peter Banyard <girgias@php.net>2019-12-04 15:17:57 +0100
commit92d5a2e48c638712bb474e187c3bffd681e2c573 (patch)
treefc026b39908bfbd61a5352660caaf125fdaeb709 /configure.ac
parent4845c3f11dce1859715287cd000fd6ff47b88aaf (diff)
downloadphp-git-92d5a2e48c638712bb474e187c3bffd681e2c573.tar.gz
Remove obsolete configure checks for isinf, isnan, and isfinite
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 19927da679..2af5c49809 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,36 +71,9 @@ extern "C++" {
#else
#include <math.h>
-#ifndef zend_isnan
-#if HAVE_DECL_ISNAN
#define zend_isnan(a) isnan(a)
-#elif defined(HAVE_FPCLASS)
-#define zend_isnan(a) ((fpclass(a) == FP_SNAN) || (fpclass(a) == FP_QNAN))
-#else
-#define zend_isnan(a) ((a) != (a))
-#endif
-#endif
-
-#if HAVE_DECL_ISINF
#define zend_isinf(a) isinf(a)
-#elif defined(INFINITY)
-/* Might not work, but is required by ISO C99 */
-#define zend_isinf(a) (((a)==INFINITY || (a)==-INFINITY)?1:0)
-#elif defined(HAVE_FPCLASS)
-#define zend_isinf(a) ((fpclass(a) == FP_PINF) || (fpclass(a) == FP_NINF))
-#else
-#define zend_isinf(a) 0
-#endif
-
-#if HAVE_DECL_ISFINITE
#define zend_finite(a) isfinite(a)
-#elif defined(HAVE_FINITE)
-#define zend_finite(a) finite(a)
-#elif defined(fpclassify)
-#define zend_finite(a) ((fpclassify((a))!=FP_INFINITE&&fpclassify((a))!=FP_NAN)?1:0)
-#else
-#define zend_finite(a) (zend_isnan(a) ? 0 : zend_isinf(a) ? 0 : 1)
-#endif
#endif
#endif /* ifndef ZEND_ACCONFIG_H_NO_C_PROTOS */