summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2005-09-16 07:06:09 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2005-09-16 07:06:09 +0000
commitde467bef0dadcdb65db63bd806ed3952e84e1cce (patch)
tree9bdc97aba058088fff206c48036e5ef71d50f140 /configure.ac
parent58cc0f178a47ae514b719e968e12b33a7f33ffe4 (diff)
downloadpaxutils-de467bef0dadcdb65db63bd806ed3952e84e1cce.tar.gz
Merge changes from gnulib for file system sub-second time stamps.
* configure.ac: Remove checks for struct stat.st_spare1, struct stat.st_atim.tv_nsec, struct stat.st_atimespec.tv_nsec, struct stat.st_atimensec, as gnulib now does this for us. Similarly for LIB_CLOCK_GETTIME.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index f1177e8..be1c983 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,27 +90,6 @@ PU_RMT
PU_RTAPELIB
PU_SYSTEM
-AC_CHECK_MEMBERS([struct stat.st_spare1, struct stat.st_atim.tv_nsec, struct stat.st_atimespec.tv_nsec, struct stat.st_atimensec], , ,
- [
-#include <sys/types.h>
-#include <sys/stat.h>])
-
-# Save and restore LIBS so e.g., -lrt, isn't added to it. Otherwise, *all*
-# programs in the package would end up linked with that potentially-shared
-# library, inducing unnecessary run-time overhead.
-
-# Solaris 2.5.1 needs -lposix4 to get the clock_gettime function.
-# Solaris 7 prefers the library name -lrt to the obsolescent name -lposix4.
-tar_save_LIBS=$LIBS
- LIB_CLOCK_GETTIME=
- AC_SEARCH_LIBS(clock_gettime, [rt posix4])
- case "$ac_cv_search_clock_gettime" in
- -l*) LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettime;;
- esac
- AC_SUBST(LIB_CLOCK_GETTIME)
- AC_CHECK_FUNCS(clock_gettime)
-LIBS=$tar_save_LIBS
-
AC_CHECK_FUNCS(fsync lstat mkfifo readlink strerror symlink setlocale utimes)
AC_CHECK_DECLS([getgrgid],,, [#include <grp.h>])
AC_CHECK_DECLS([getpwuid],,, [#include <pwd.h>])
@@ -238,7 +217,7 @@ AM_GNU_GETTEXT_VERSION(0.12.1)
# Initialize the test suite.
# AC_CONFIG_TESTDIR(tests)
-# AC_CONFIG_FILES([tests/Makefile tests/atlocal])
+# AC_CONFIG_FILES([tests/Makefile tests/atlocal])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
AC_SUBST(BACKUP_LIBEXEC_SCRIPTS)
@@ -265,4 +244,3 @@ AC_OUTPUT([Makefile\
paxlib/Makefile\
po/Makefile.in\
paxtest/Makefile])
-