summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2006-03-08 00:28:51 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2006-03-08 00:28:51 +0000
commita6a24beb47a6253f141c8fb9c9d67d6e5aa30683 (patch)
tree1385998fe788f2a11d8d7421c737edf84a225e96 /configure.ac
parent1fd0bd449b1706b5c7eb549054d6fc089dcd766c (diff)
downloadpaxutils-a6a24beb47a6253f141c8fb9c9d67d6e5aa30683.tar.gz
* configure.ac (AC_CHECK_HEADERS): Don't check for sys/time.h,
since we no longer use HAVE_SYS_TIME_H. (AC_CHECK_DECLS): Don't check for 'time', since we assume C89 or better. * lib/system.h: Include <unistd.h> unconditionally, since we now assume the unistd module. (time): Remove decl; not needed, since we assume C89 or better. Don't bother checking for HAVE_SYS_TIME_H when deciding whether to include <sys/time.h>, since TIME_WITH_SYS_TIME implies sys/time.h exists. * m4/system.m4 (PU_SYSTEM): Don't check for unistd.h or sys/time.h, or for time or valloc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index be1c983..5f45ab6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
# This file is part of GNU paxutils
#
-# Copyright (C) 2005 Free Software Foundation, Inc.
+# Copyright (C) 2005, 2006 Free Software Foundation, Inc.
#
# GNU paxutils is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by the
@@ -35,7 +35,7 @@ AC_CHECK_HEADERS(fcntl.h linux/fd.h memory.h net/errno.h \
sgtty.h string.h \
sys/param.h sys/device.h sys/gentape.h \
sys/inet.h sys/io/trioctl.h \
- sys/mtio.h sys/time.h sys/tprintf.h sys/tape.h \
+ sys/mtio.h sys/tprintf.h sys/tape.h \
unistd.h locale.h)
AC_CHECK_HEADERS([sys/buf.h], [], [],
@@ -93,7 +93,6 @@ PU_SYSTEM
AC_CHECK_FUNCS(fsync lstat mkfifo readlink strerror symlink setlocale utimes)
AC_CHECK_DECLS([getgrgid],,, [#include <grp.h>])
AC_CHECK_DECLS([getpwuid],,, [#include <pwd.h>])
-AC_CHECK_DECLS([time],,, [#include <time.h>])
# Set LIB_SETSOCKOPT to -lnsl -lsocket if necessary.
tar_save_LIBS=$LIBS