summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2021-09-11 16:23:09 +0200
committerJörg Thalheim <joerg@thalheim.io>2021-09-11 16:24:35 +0200
commitd2f4d2e3b50c6669b14c8797aca675a825b77a74 (patch)
tree108654e8c5a91b6b6ebe431b5b884a8fd71b5d60 /flake.nix
parent88177c44f8fd9fa77ac0f1e24a5cec84dd01dcff (diff)
downloadpatchelf-d2f4d2e3b50c6669b14c8797aca675a825b77a74.tar.gz
also build with clang
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 9 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 0f9dc0e..7ce2224 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,18 +23,13 @@
{
overlay = final: prev: {
- patchelf-new = final.stdenv.mkDerivation {
- pname = "patchelf";
+ patchelf-new = final.callPackage ./patchelf.nix {
inherit version;
src = self;
- nativeBuildInputs = [ final.autoreconfHook ];
- doCheck = true;
};
-
};
hydraJobs = {
-
tarball =
pkgs.releaseTools.sourceTarball rec {
name = "patchelf-tarball";
@@ -58,7 +53,13 @@
build = forAllSystems (system: nixpkgsFor.${system}.patchelf-new);
build-sanitized = forAllSystems (system: nixpkgsFor.${system}.patchelf-new.overrideAttrs (old: {
configureFlags = [ "--with-asan " "--with-ubsan" ];
+ # -Wno-unused-command-line-argument is for clang, which does not like
+ # our cc wrapper arguments
+ CFLAGS = "-Werror -Wno-unused-command-line-argument";
}));
+ build-sanitized-clang = forAllSystems (system: self.hydraJobs.build-sanitized.${system}.override {
+ stdenv = pkgs.libcxxStdenv;
+ });
release = pkgs.releaseTools.aggregate
{ name = "patchelf-${self.hydraJobs.tarball.version}";
@@ -68,6 +69,8 @@
self.hydraJobs.build.i686-linux
self.hydraJobs.build-sanitized.x86_64-linux
self.hydraJobs.build-sanitized.i686-linux
+ self.hydraJobs.build-sanitized-clang.x86_64-linux
+ self.hydraJobs.build-sanitized-clang.i686-linux
];
meta.description = "Release-critical builds";
};