summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2021-08-25 21:22:10 +0000
committerJörg Thalheim <joerg@thalheim.io>2021-08-25 21:22:11 +0000
commit893e2988c71ada4b0ae086cf32035820ed3949a3 (patch)
treeaa829aac461f28d3d26f9a2c4f4de1adea4b4695 /flake.nix
parent38cb5c8e0d28ce4ec0eaa44346f489a193a07baf (diff)
downloadpatchelf-893e2988c71ada4b0ae086cf32035820ed3949a3.tar.gz
fix aarch64 build
also fix evaluation of nix develop on aarch64. See https://hydra.nixos.org/eval/1698785#tabs-still-fail for details.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/flake.nix b/flake.nix
index 6295165..1411fe1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -15,19 +15,19 @@
overlays = [ self.overlay ];
}
);
-
+ version = builtins.readFile ./version
+ + "." + builtins.substring 0 8 self.lastModifiedDate
+ + "." + (self.shortRev or "dirty");
pkgs = nixpkgsFor.${"x86_64-linux"};
-
in
{
-
overlay = final: prev: {
-
patchelf-new = final.stdenv.mkDerivation {
- name = "patchelf-${self.hydraJobs.tarball.version}";
- src = "${self.hydraJobs.tarball}/tarballs/*.tar.bz2";
- nativeBuildInputs = [ pkgs.autoreconfHook ];
+ pname = "patchelf";
+ inherit version;
+ src = self;
+ nativeBuildInputs = [ final.autoreconfHook ];
doCheck = true;
};
@@ -38,9 +38,7 @@
tarball =
pkgs.releaseTools.sourceTarball rec {
name = "patchelf-tarball";
- version = builtins.readFile ./version
- + "." + builtins.substring 0 8 self.lastModifiedDate
- + "." + (self.shortRev or "dirty");
+ inherit version;
versionSuffix = ""; # obsolete
src = self;
preAutoconf = "echo ${version} > version";