summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-11-06 15:38:38 +0100
committerJörg Thalheim <joerg@thalheim.io>2022-11-06 15:38:38 +0100
commitb0599fe776e063156f5d18f5b9b2c7a23f7c62ae (patch)
tree7a47d1797b06dd46bc89edc695272470a399e7a9 /configure.ac
parentc543a45f7fb206e797944de928c0bec6936e4999 (diff)
downloadpatchelf-b0599fe776e063156f5d18f5b9b2c7a23f7c62ae.tar.gz
make objdump/objcopy/readelf configurable and respect cross-compiling related prefixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4729e4f..4129920 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,10 @@ AM_INIT_AUTOMAKE([1.11.1 -Wall -Werror dist-bzip2 foreign color-tests parallel-t
AC_CONFIG_MACRO_DIR([m4])
AC_CHECK_TOOL([STRIP], [strip])
+# Those are only used in tests, hence we gracefully degrate if they are not found.
+AC_CHECK_TOOL([OBJDUMP], [objdump], [objdump])
+AC_CHECK_TOOL([OBJCOPY], [objcopy], [objcopy])
+AC_CHECK_TOOL([READELF], [readelf], [readelf])
AM_PROG_CC_C_O
AC_PROG_CXX