summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2021-08-26 07:07:50 +0200
committerJörg Thalheim <joerg@thalheim.io>2021-08-26 07:09:35 +0200
commita9f5397ee15bd12110c1995bbaf72ae38c40baa0 (patch)
tree0a7cba86f5feff8c611625f99a4a1735f6caab83 /configure.ac
parent3113c7359841ca8d574ce4c4232e3650cb90707a (diff)
downloadpatchelf-a9f5397ee15bd12110c1995bbaf72ae38c40baa0.tar.gz
add ubsan option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d752d4..b0618f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,9 +20,14 @@ if test "$DEFAULT_PAGESIZE" != auto; then
fi
AC_ARG_WITH([asan],
- AS_HELP_STRING([--with-asan], [Link with libasan])
+ AS_HELP_STRING([--with-asan], [Build with address sanitizer])
)
AM_CONDITIONAL([WITH_ASAN], [test x"$with_asan" = xyes])
+AC_ARG_WITH([ubsan],
+ AS_HELP_STRING([--with-ubsan], [Build with undefined behavior sanitizer])
+)
+AM_CONDITIONAL([WITH_UBSAN], [test x"$with_ubsan" = xyes])
+
AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile patchelf.spec])
AC_OUTPUT