summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-10-09 14:30:02 +0200
committerJörg Thalheim <joerg@thalheim.io>2022-10-09 14:30:03 +0200
commit99211365292686b888d9f90a751062c603b48382 (patch)
treee1042e6d7f88faee18da5c0bcfc820c9562a5024 /configure.ac
parent683e41d340aea90822bb5e202eeac15688234a51 (diff)
downloadpatchelf-99211365292686b888d9f90a751062c603b48382.tar.gz
fix c++17 check
https://github.com/NixOS/patchelf/issues/393 Appearantly there are compilers that support -std=c++17 but do not really support c++17.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0ea1fa7..4729e4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,17 +28,12 @@ AC_ARG_WITH([asan],
)
AM_CONDITIONAL([WITH_ASAN], [test x"$with_asan" = xyes])
+AX_CXX_COMPILE_STDCXX([17], [noext], [])
+
AC_ARG_WITH([ubsan],
AS_HELP_STRING([--with-ubsan], [Build with undefined behavior sanitizer])
)
AM_CONDITIONAL([WITH_UBSAN], [test x"$with_ubsan" = xyes])
-CPLUSPLUS=
-AX_CHECK_COMPILE_FLAG([-std=c++17], [CPLUSPLUS=17], [], [$WERROR])
-
-if test -z "$CPLUSPLUS"; then
- AC_MSG_ERROR([Your compiler does not have the necessary C++17 support! Cannot proceed.])
-fi
-
AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile patchelf.spec])
AC_OUTPUT