summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Kolesa <dkolesa@igalia.com>2022-02-17 20:12:18 +0100
committerDaniel Kolesa <dkolesa@igalia.com>2022-03-12 04:44:18 +0100
commitaca9e8e6a73c79554f320b85aafb4cb01e91ac5a (patch)
treef7f878b362fe2a78a0e5cc8d52ec670b39da7a80 /Makefile.am
parent2f11977da52d0ad01a3fba3e680d6eda92210f11 (diff)
downloadostree-aca9e8e6a73c79554f320b85aafb4cb01e91ac5a.tar.gz
glib: bump glib requirement to 2.66 and port to GUri
This removes the old SoupURI copypasta from previous generation of libsoup and opens up a path for a simple libsoup3 port.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ce90ca45..6eb88388 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,7 +29,7 @@ AM_CPPFLAGS += -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
-DOSTREE_COMPILATION \
-DG_LOG_DOMAIN=\"OSTree\" \
-DOSTREE_GITREV='"$(OSTREE_GITREV)"' \
- -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_44 '-DGLIB_VERSION_MAX_ALLOWED=G_ENCODE_VERSION(2,50)' \
+ -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_66 '-DGLIB_VERSION_MAX_ALLOWED=G_ENCODE_VERSION(2,70)' \
-DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_40 '-DSOUP_VERSION_MAX_ALLOWED=G_ENCODE_VERSION(2,48)'
# For strict aliasing, see https://bugzilla.gnome.org/show_bug.cgi?id=791622
AM_CFLAGS += -std=gnu99 -fno-strict-aliasing $(WARN_CFLAGS)