summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2022-11-11 15:08:10 -0500
committerColin Walters <walters@verbum.org>2022-11-11 17:09:35 -0500
commit6f68e3dc4e23cf879645ad4ef69cdff28a6ae77b (patch)
tree6c61276e0f6997f409c3c8c8089cebedd568d22d /Cargo.toml
parentbef337e1bd8451783bbc1ace34e6a08cd978d32b (diff)
downloadostree-6f68e3dc4e23cf879645ad4ef69cdff28a6ae77b.tar.gz
rust: Update to cap-std 1.0
This was one source of our semver bumps; let's switch to 1.0.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a681ab4c..cb83c4dc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -38,8 +38,8 @@ members = [".", "rust-bindings/sys"]
[dependencies]
bitflags = "1.2.1"
-cap-std = { version = "0.25", optional = true}
-io-lifetimes = { version = "0.7", optional = true}
+cap-std = { version = "1.0", optional = true}
+io-lifetimes = { version = "1.0", optional = true}
ffi = { package = "ostree-sys", path = "rust-bindings/sys", version = "0.11.0" }
gio = "0.15"
glib = "0.15"
@@ -53,7 +53,7 @@ thiserror = "1.0.20"
maplit = "1.0.2"
openat = "0.1.19"
tempfile = "3"
-cap-tempfile = "0.25"
+cap-tempfile = "1.0"
[features]
cap-std-apis = ["cap-std", "io-lifetimes", "v2017_10"]