summaryrefslogtreecommitdiff
path: root/orc-test/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'orc-test/meson.build')
-rw-r--r--orc-test/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/orc-test/meson.build b/orc-test/meson.build
new file mode 100644
index 0000000..e0597d1
--- /dev/null
+++ b/orc-test/meson.build
@@ -0,0 +1,12 @@
+orc_test_headers = ['orctest.h', 'orcarray.h', 'orcrandom.h', 'orcprofile.h']
+orc_test_sources = ['orctest.c', 'orcarray.c', 'orcrandom.c', 'orcprofile.c']
+
+install_headers(orc_test_headers, subdir : 'orc-' + orc_api + '/orc-test')
+
+orc_test_lib = shared_library('orc-test-' + orc_api, orc_test_sources,
+ c_args : [ orc_c_args , '-DORC_ENABLE_UNSTABLE_API' ],
+ dependencies : [libm, orc_dep],
+ install : true)
+
+orc_test_dep = declare_dependency(include_directories : orc_inc,
+ link_with : orc_test_lib)