summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalph Giles <giles@mozilla.com>2013-11-19 17:50:05 +1300
committerRalph Giles <giles@mozilla.com>2013-11-19 18:12:55 +1300
commitd5cb06305b6707a51d976cf79ae513c2fe023382 (patch)
tree51850e04202a14eb796c1f291a710ddf954611e3 /Makefile.am
parentca5bf5b0496137bc57e3a0dfd0fa829a53736728 (diff)
downloadopus-d5cb06305b6707a51d976cf79ae513c2fe023382.tar.gz
Fix 'make distclean'.
Automake's dependency tracking seems to be confused by our asm generation double-indirection. It's sufficient to have just CLEANFILES = $(CELT_AM_SOURCES_ARM_ASM:.s.in=-gnu.S) to fix the error about 'armopts-gnu.S' not being cleaned, but celt_pitch_xcorr_arm-gnu.S is also not cleaned without raising a warning. Therefore we explicitly clean both sets of ARM_ASM.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cbedb502..ca8ed4d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,9 @@ BUILT_SOURCES = $(CELT_SOURCES_ARM_ASM:.s=-gnu.S) \
endif
endif
+CLEANFILES = $(CELT_SOURCES_ARM_ASM:.s=-gnu.S) \
+ $(CELT_AM_SOURCES_ARM_ASM:.s.in=-gnu.S)
+
include celt_headers.mk
include silk_headers.mk
include opus_headers.mk