summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-02-17 13:04:45 +0100
committerPetr Štetiar <ynezz@true.cz>2022-02-17 13:26:44 +0100
commitaa8c48e9c139654814c88f9148118c707507e275 (patch)
treea4d56d18e284349d57d1e2810d105d63b5a7f058
parent868fd8812f477c110f9c6c5252c0bd172167b94c (diff)
downloadustream-ssl-aa8c48e9c139654814c88f9148118c707507e275.tar.gz
cmake: add a possibility to set library version
Add a new `ABIVERSION` define which allows to control the SOVERSION used for the built shared library. This is needed for downstream packaging to properly track breaking ABI changes when updating to newer versions of the library. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c98b12a..f53e726 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,3 +48,7 @@ INSTALL(FILES ustream-ssl.h
INSTALL(TARGETS ustream-ssl
LIBRARY DESTINATION lib
)
+
+IF(ABIVERSION)
+ SET_TARGET_PROPERTIES(ustream-ssl PROPERTIES VERSION ${ABIVERSION})
+ENDIF()