summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Dale <richard.dale@codethink.co.uk>2015-05-14 08:37:24 +0000
committerRichard Dale <richard.dale@codethink.co.uk>2015-05-20 04:22:25 +0100
commit7c97b7862acb854baad6fbce9b12476996677f62 (patch)
tree8655939e273b44f4b5a42e0e6554819cf34211e9
parent99f729378f69b2985c559bc8639b2edd06d75233 (diff)
downloaduhttpd-baserock/json-c-fix.tar.gz
Change include to <json-c/json.h>baserock/json-c-fix
Change library name to json-c
-rw-r--r--CMakeLists.txt2
-rw-r--r--uhttpd-ubus.h2
2 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1692bf4..f556877 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,7 @@ ENDIF()
IF(UBUS_SUPPORT)
ADD_DEFINITIONS(-DHAVE_UBUS)
ADD_LIBRARY(uhttpd_ubus MODULE uhttpd-ubus.c)
- TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus json blobmsg_json)
+ TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus json-c blobmsg_json)
SET(PLUGINS ${PLUGINS} uhttpd_ubus)
ENDIF()
diff --git a/uhttpd-ubus.h b/uhttpd-ubus.h
index 777ce27..fdff845 100644
--- a/uhttpd-ubus.h
+++ b/uhttpd-ubus.h
@@ -23,7 +23,7 @@
#include <libubus.h>
#include <libubox/avl.h>
#include <libubox/blobmsg_json.h>
-#include <json/json.h>
+#include <json-c/json.h>
#define UH_UBUS_MAX_POST_SIZE 4096