summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-04 13:34:40 +0200
committerFelix Fietkau <nbd@openwrt.org>2014-05-04 13:39:43 +0200
commit3ddb765bd513a70d128810b65c3a45f81690782e (patch)
treea3644b31c52ffa312ab64a87423d6f208dbd846d /CMakeLists.txt
parent63a984dbdf8a4d1249838e0708a4bed2dfaff476 (diff)
downloaduclient-3ddb765bd513a70d128810b65c3a45f81690782e.tar.gz
http: make ustream_ssl optional, only use provided ssl context
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d48175..f7fd051 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,10 +13,10 @@ IF(APPLE)
ENDIF()
ADD_LIBRARY(uclient SHARED uclient.c uclient-http.c uclient-utils.c)
-TARGET_LINK_LIBRARIES(uclient ubox ustream-ssl)
+TARGET_LINK_LIBRARIES(uclient ubox dl)
ADD_EXECUTABLE(uclient-example uclient-example.c)
-TARGET_LINK_LIBRARIES(uclient-example uclient)
+TARGET_LINK_LIBRARIES(uclient-example uclient ustream-ssl)
INSTALL(FILES uclient.h uclient-utils.h
DESTINATION include/libubox