summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Gstädtner <thomas@gstaedtner.net>2013-03-04 19:05:08 +0100
committerFelix Fietkau <nbd@openwrt.org>2013-03-04 19:11:15 +0100
commit29a2ed2f17350f29680fd7cdcae9d3a1e3e5886b (patch)
treedcc29831a0dea8fdac108a13445de843e587ae28 /CMakeLists.txt
parenta15a09aed4f72424e5533375cb8de0763fb2ea31 (diff)
downloadubus-29a2ed2f17350f29680fd7cdcae9d3a1e3e5886b.tar.gz
make UBUS_UNIX_SOCKET configurable via cmake
this is mainly useful to have a single location to read the setting from, when it is used multiple times at build time (which it will in a following patch) :)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1634b9b..01b43c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,9 @@ OPTION(BUILD_LUA "build Lua plugin" ON)
OPTION(BUILD_EXAMPLES "build examples" ON)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+SET(UBUS_UNIX_SOCKET "/var/run/ubus.sock")
+
+ADD_DEFINITIONS( -DUBUS_UNIX_SOCKET="${UBUS_UNIX_SOCKET}")
IF(APPLE)
INCLUDE_DIRECTORIES(/opt/local/include)