summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-04-21 20:06:59 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-05-29 21:43:54 +0200
commit7c6cf551df1eb4b59b2576c73db7ad30ac4ce396 (patch)
treec48475993df58e6cf1a20c838129d633cd6a08bd /CMakeLists.txt
parentd42b21ed9305b91f300f0cebda77e5792f29fc07 (diff)
downloadprocd-7c6cf551df1eb4b59b2576c73db7ad30ac4ce396.tar.gz
system: always support staged sysupgrade
In preparation for switching all targets to the staged sysupgrade mechanism, upgraded is always built, and the "nandupgrade" ubus method is renamed to "sysupgrade". To make the migration easier, support for the old name "nandupgrade" and the "upgrade" method that will become unused with the staged sysupgrade is retained for now. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 444dd20..0729459 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,9 +40,7 @@ IF(ZRAM_TMPFS)
SET(SOURCES_ZRAM initd/zram.c)
ENDIF()
-IF(BUILD_UPGRADED)
- add_subdirectory(upgraded)
-ENDIF()
+add_subdirectory(upgraded)
ADD_EXECUTABLE(procd ${SOURCES})
TARGET_LINK_LIBRARIES(procd ${LIBS})