summaryrefslogtreecommitdiff
path: root/toolchain/glibc
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-08-07 00:00:36 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-21 11:35:32 +0100
commitde1f0cb72f52c18058dc5d5be73a1b145c565dc5 (patch)
tree58dd468c2008459b08238ba45de3883ec9fcc089 /toolchain/glibc
parenta9b2b4ddc47eccd923ca2cd6c491e0ce14aeb26b (diff)
downloadopenwrt-de1f0cb72f52c18058dc5d5be73a1b145c565dc5.tar.gz
toolchain: glibc: Update to glibc 2.36
This updates to glibc to version 2.36. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'toolchain/glibc')
-rw-r--r--toolchain/glibc/common.mk6
-rw-r--r--toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch4
-rw-r--r--toolchain/glibc/patches/200-add-dl-search-paths.patch2
3 files changed, 6 insertions, 6 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 107245472a..d1c440c6c7 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=glibc
-PKG_VERSION:=2.35
+PKG_VERSION:=2.36
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=813a8d01716d4e099ec57194a93b14fa08b4beca
-PKG_MIRROR_HASH:=8c8d92dde334f0e0f9a0949d25b2950db513ce8723c31ae0b0ef64730a00322f
+PKG_SOURCE_VERSION:=3aae843e9e9e6a2502e98ff44d2671b20a023f8e
+PKG_MIRROR_HASH:=29bdd6ca699f297de500ea457741d0706d57a69836fa7d45e6cc2cc20484cad4
PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
diff --git a/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch b/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch
index 7dfc8a5582..c9db703938 100644
--- a/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch
+++ b/toolchain/glibc/patches/050-Revert-Disallow-use-of-DES-encryption-functions-in-n.patch
@@ -82,7 +82,7 @@ provides them.
int totfails = 0;
int main (int argc, char *argv[]);
-@@ -120,13 +104,3 @@ put8 (char *cp)
+@@ -119,13 +103,3 @@ put8 (char *cp)
printf("%02x", t);
}
}
@@ -627,7 +627,7 @@ provides them.
range [FROM - N + 1, FROM - 1]. If N is odd the first byte in FROM
--- a/stdlib/stdlib.h
+++ b/stdlib/stdlib.h
-@@ -971,6 +971,12 @@ extern int getsubopt (char **__restrict
+@@ -984,6 +984,12 @@ extern int getsubopt (char **__restrict
#endif
diff --git a/toolchain/glibc/patches/200-add-dl-search-paths.patch b/toolchain/glibc/patches/200-add-dl-search-paths.patch
index fd4af3694a..e927d86f23 100644
--- a/toolchain/glibc/patches/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -618,6 +618,9 @@ else
+@@ -631,6 +631,9 @@ else
default-rpath = $(libdir)
endif