summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules144
1 files changed, 123 insertions, 21 deletions
diff --git a/debian/rules b/debian/rules
index c6b2e85..ccde20e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,8 +20,6 @@ ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS)))
CC =diet -v -Os gcc -nostdinc
endif
-DIR =$(shell pwd)/debian/dropbear
-
patch: deb-checkdir patch-stamp
patch-stamp:
for i in `ls -1 debian/diff/*.diff || :`; do \
@@ -36,13 +34,15 @@ config.status: patch-stamp configure
--build='$(DEB_BUILD_GNU_TYPE)' --prefix=/usr \
--mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info \
$(CONFFLAGS)
+ $(MAKE) clean
build: deb-checkdir build-stamp
build-stamp: config.status
$(MAKE) CC='$(CC)' LD='$(CC)'
touch build-stamp
-clean: deb-checkdir deb-checkuid
+clean: DIR=$(shell pwd)/debian/dropbear
+clean: deb-checkdir deb-checkuid
test ! -r Makefile || $(MAKE) distclean
rm -f libtomcrypt/Makefile libtommath/Makefile
test ! -e patch-stamp || \
@@ -51,22 +51,117 @@ clean: deb-checkdir deb-checkuid
done
rm -f patch-stamp build-stamp config.log config.status
rm -rf '$(DIR)'
+ rm -rf '$(DIR)'-client
+ rm -rf '$(DIR)'-server
+ rm -rf '$(DIR)'-keyutils
+ rm -rf '$(DIR)'-scp
rm -f debian/files debian/substvars debian/copyright changelog
-install: deb-checkdir deb-checkuid build-stamp
- rm -rf '$(DIR)'
+install-server: DIR=$(shell pwd)/debian/dropbear-server
+install-server: deb-checkdir deb-checkuid config.status
+ rm -f '$(DIR)'
+ rm *.o
+ $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbear dropbearkey dropbearconvert" MULTI=1
install -d -m0755 '$(DIR)'/etc/dropbear
# programs
+ install -d -m0755 '$(DIR)'/usr/bin
install -d -m0755 '$(DIR)'/usr/sbin
- install -m0755 dropbear '$(DIR)'/usr/sbin/dropbear
+ install -d -m0755 '$(DIR)'/usr/lib/dropbear
+ install -m0755 dropbearmulti \
+ '$(DIR)'/usr/lib/dropbear/dropbearmulti
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/dropbearkey
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/sbin/dropbear
+ ln -s dropbearmulti '$(DIR)'/usr/lib/dropbear/dropbearconvert
+ # init and run scripts
+ install -d -m0755 '$(DIR)'/etc/init.d
+ install -m0755 debian/dropbear.init '$(DIR)'/etc/init.d/dropbear
+ install -m0755 debian/service/run '$(DIR)'/etc/dropbear/run
+ install -d -m0755 '$(DIR)'/etc/dropbear/log
+ install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run
+ ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main
+ install -d -m0755 '$(DIR)'/usr/share/man/man8
+ for i in dropbear.8 ; do \
+ install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \
+ done
+ gzip -9 '$(DIR)'/usr/share/man/man8/*.8
+ # copyright, changelog
+ cat debian/copyright.in LICENSE > debian/copyright
+ test -r changelog || ln -s CHANGES changelog
+ $(STRIP) -R .comment -R .note '$(DIR)'/usr/lib/dropbear/*
+
+ install -d -m0755 '$(DIR)'/DEBIAN
+ test '$(CC)' != 'gcc' || \
+ dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
+
+install-client: DIR=$(shell pwd)/debian/dropbear-client
+install-client: deb-checkdir deb-checkuid config.status
+ rm -f '$(DIR)'
+ rm *.o
+ $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS=dbclient dbclient
install -d -m0755 '$(DIR)'/usr/bin
install -m0755 dbclient '$(DIR)'/usr/bin/dbclient
- install -m0755 dropbearkey '$(DIR)'/usr/bin/dropbearkey
+ install -d -m0755 '$(DIR)'/usr/share/man/man1
+ install -m644 dbclient.1 '$(DIR)'/usr/share/man/man1/
+ gzip -9 '$(DIR)'/usr/share/man/man1/*.1
+ $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/*
+
+ install -d -m0755 '$(DIR)'/DEBIAN
+ test '$(CC)' != 'gcc' || \
+ dpkg-shlibdeps '$(DIR)'/usr/bin/*
+
+install-keyutils: DIR=$(shell pwd)/debian/dropbear-keyutils
+install-keyutils: deb-checkdir deb-checkuid config.status
+ rm -f '$(DIR)'
+ rm *.o
+ $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert" MULTI=1
+ install -d -m0755 '$(DIR)'/usr/bin
+ install -d -m0755 '$(DIR)'/usr/lib/dropbear
+ install -m0755 dropbearmulti \
+ '$(DIR)'/usr/lib/dropbear/dropbearmulti
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/dropbearkey
+ ln -s dropbearmulti '$(DIR)'/usr/lib/dropbear/dropbearconvert
+ install -d -m0755 '$(DIR)'/usr/share/man/man8
+ for i in dropbearkey.8; do \
+ install -m644 $$i '$(DIR)'/usr/share/man/man8/ || exit 1; \
+ done
+ gzip -9 '$(DIR)'/usr/share/man/man8/*.8
+ $(STRIP) -R .comment -R .note \
+ '$(DIR)'/usr/lib/dropbear/*
+
+ install -d -m0755 '$(DIR)'/DEBIAN
+ test '$(CC)' != 'gcc' || \
+ dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
+
+install-scp: DIR=$(shell pwd)/debian/dropbear-scp
+install-scp: deb-checkdir deb-checkuid config.status
+ rm -f '$(DIR)'
+ rm *.o
+ $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="scp" scp
+ install -d -m0755 '$(DIR)'/usr/bin
+ install -m0755 scp '$(DIR)'/usr/bin/scp
+ $(STRIP) -R .comment -R .note '$(DIR)'/usr/bin/*
+
+ install -d -m0755 '$(DIR)'/DEBIAN
+ test '$(CC)' != 'gcc' || \
+ dpkg-shlibdeps '$(DIR)'/usr/bin/*
+
+install-multi: DIR=$(shell pwd)/debian/dropbear
+install-multi: deb-checkdir deb-checkuid config.status
+ rm -f '$(DIR)'
+ rm *.o
+ $(MAKE) CC='$(CC)' LD='$(LD)' PROGRAMS="dropbearkey dropbearconvert scp dropbear dbclient" MULTI=1
+ install -d -m0755 '$(DIR)'/etc/dropbear
+ # programs
+ install -d -m0755 '$(DIR)'/usr/bin
+ install -d -m0755 '$(DIR)'/usr/sbin
install -d -m0755 '$(DIR)'/usr/lib/dropbear
- install -m0755 dropbearconvert \
- '$(DIR)'/usr/lib/dropbear/dropbearconvert
- $(STRIP) -R .comment -R .note '$(DIR)'/usr/sbin/* \
- '$(DIR)'/usr/bin/* '$(DIR)'/usr/lib/dropbear/*
+ install -m0755 dropbearmulti \
+ '$(DIR)'/usr/lib/dropbear/dropbearmulti
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/dropbearkey
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/dbclient
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/bin/scp
+ ln -s ../lib/dropbear/dropbearmulti '$(DIR)'/usr/sbin/dropbear
+ ln -s dropbearmulti '$(DIR)'/usr/lib/dropbear/dropbearconvert
# init and run scripts
install -d -m0755 '$(DIR)'/etc/init.d
install -m0755 debian/dropbear.init '$(DIR)'/etc/init.d/dropbear
@@ -74,7 +169,6 @@ install: deb-checkdir deb-checkuid build-stamp
install -d -m0755 '$(DIR)'/etc/dropbear/log
install -m0755 debian/service/log '$(DIR)'/etc/dropbear/log/run
ln -s /var/log/dropbear '$(DIR)'/etc/dropbear/log/main
- # man pages
install -d -m0755 '$(DIR)'/usr/share/man/man8
install -d -m0755 '$(DIR)'/usr/share/man/man1
install -m644 dropbear.8 '$(DIR)'/usr/share/man/man8/
@@ -83,18 +177,26 @@ install: deb-checkdir deb-checkuid build-stamp
done
gzip -9 '$(DIR)'/usr/share/man/man8/*.8
gzip -9 '$(DIR)'/usr/share/man/man1/*.1
- # copyright, changelog
- cat debian/copyright.in LICENSE >debian/copyright
- test -r changelog || ln -s CHANGES changelog
+ $(STRIP) -R .comment -R .note '$(DIR)'/usr/lib/dropbear/*
+ install -d -m0755 '$(DIR)'/DEBIAN
+ test '$(CC)' != 'gcc' || \
+ dpkg-shlibdeps '$(DIR)'/usr/lib/dropbear/*
+
+install: install-client install-server install-keyutils install-multi install-scp
binary-indep:
-binary-arch: install dropbear.deb
- test '$(CC)' != 'gcc' || \
- dpkg-shlibdeps '$(DIR)'/usr/sbin/* '$(DIR)'/usr/bin/* \
- '$(DIR)'/usr/lib/dropbear/*
- dpkg-gencontrol -isp -pdropbear -P'$(DIR)'
- dpkg -b '$(DIR)' ..
+binary-arch: install dropbear.deb dropbear-server.deb dropbear-keyutils.deb dropbear-scp.deb dropbear-client.deb
+ dpkg-gencontrol -isp -pdropbear -P'$(shell pwd)/debian'/dropbear
+ dpkg-gencontrol -isp -pdropbear-server -P'$(shell pwd)/debian'/dropbear-server
+ dpkg-gencontrol -isp -pdropbear-client -P'$(shell pwd)/debian'/dropbear-client
+ dpkg-gencontrol -isp -pdropbear-keyutils -P'$(shell pwd)/debian'/dropbear-keyutils
+ dpkg-gencontrol -isp -pdropbear-scp -P'$(shell pwd)/debian'/dropbear-scp
+ dpkg -b '$(shell pwd)/debian'/dropbear ..
+ dpkg -b '$(shell pwd)/debian'/dropbear-server ..
+ dpkg -b '$(shell pwd)/debian'/dropbear-keyutils ..
+ dpkg -b '$(shell pwd)/debian'/dropbear-scp ..
+ dpkg -b '$(shell pwd)/debian'/dropbear-client ..
binary: binary-arch binary-indep